Visual Studio – “The type or namespace name ‘Json’ does not exist in the namespace ‘System.Runtime.Serialization’ (are you missing an assembly reference?)”

The type or namespace name ‘Json’ does not exist in the namespace ‘System.Runtime.Serialization’ (are you missing an assembly reference?)

in Italian:

Il tipo o il nome dello spazio dei nomi ‘Json’ non esiste nello spazio dei nomi ‘System.Runtime.Serialization'; probabilmente manca un riferimento a un assembly

Solution:

Add the following References to your project:

System.Runtime.Serialization
System.ServiceModel.Web

In Solution Explorer, right-click on the project node and click Add Reference to select the dll files.
Remember to add using or Imports lines inside your file.

Did my solution solve your problem? Leave a reply.

Published by

Eclipses

I think that everyone in his life has a mission to follow... behold, mine is to help the man to do its job, because for me the computer was essentially created for this goal. To make software easier, it requires much work, but I'm not afraid to write miles of code it's my profession and my passion; headphones, monitor in front and keyboard with the keys faded so every day until sunset. I'm very friendly and sociable, I work well in team and I have a good attitude in problems solving.

12 thoughts on “Visual Studio – “The type or namespace name ‘Json’ does not exist in the namespace ‘System.Runtime.Serialization’ (are you missing an assembly reference?)””

    1. Hi Tom,
      thank you for your comment. Have you also added “using” or “import” inside your file? Is the error message always the same?
      Let me know

    1. eclipses on July 2, 2012 at 12:40 am

      Hi az,
      thank you for your comment. Have you also added “using” or “import” inside your file? Is the error message always the same?
      Let me know

  1. I got the same error. and adding reference didn’t help solve the problem. and the error message remained the same.
    any suggestions?
    :Error 1 The type or namespace name ‘Json’ does not exist in the namespace ‘System’ (are you missing an assembly reference?)

    1. Hi shiroki,
      thank you for your comment. Have you also added “using” or “import” inside your file? You have to add it inside every file when you use Json.
      Let me know

Leave a Reply