Categories
Android Eclipse SDK

ADT Plugin for Eclipse – “Cannot complete the install because one or more required items could not be found. Software being installed: Android Development Tools 15.0.0.v201110251216-213216 (com.android.ide.eclipse.adt.feature.group 15.0.0.v201110251216-213216) Missing requirement: Android Development Tools 15.0.0.v201110251216-213216 (com.android.ide.eclipse.adt.feature.group 15.0.0.v201110251216-213216) requires ‘org.eclipse.wst.sse.core 0.0.0’ but it could not be found”

When you try to download the ADT Plugin show the following error message:

Cannot complete the install because one or more required items could not be found.
Software being installed: Android Development Tools 15.0.0.v201110251216-213216 (com.android.ide.eclipse.adt.feature.group 15.0.0.v201110251216-213216)
Missing requirement: Android Development Tools 15.0.0.v201110251216-213216 (com.android.ide.eclipse.adt.feature.group 15.0.0.v201110251216-213216) requires ‘org.eclipse.wst.sse.core 0.0.0’ but it could not be found

Solution:

Right-click on Eclipse.exe file or his shortcut and chose “Run As Administrator” then

  1. Select Help > Install New Software….
  2. Click Add, in the top-right corner.
  3. In the Add Repository dialog that appears, enter “ADT Plugin” for the Name and the following URL for the Location:
    https://dl-ssl.google.com/android/eclipse/
  4. Click OK
  5. In the Available Software dialog, select the checkbox next to Developer Tools and click Next.
  6. In the next window, you’ll see a list of the tools to be downloaded. Click Next.
  7. Read and accept the license agreements, then click Finish.Note: If you get a security warning saying that the authenticity or validity of the software can’t be established, click OK.
  8. When the installation completes, restart Eclipse.

Did my solution solve your problem?

14 replies on “ADT Plugin for Eclipse – “Cannot complete the install because one or more required items could not be found. Software being installed: Android Development Tools 15.0.0.v201110251216-213216 (com.android.ide.eclipse.adt.feature.group 15.0.0.v201110251216-213216) Missing requirement: Android Development Tools 15.0.0.v201110251216-213216 (com.android.ide.eclipse.adt.feature.group 15.0.0.v201110251216-213216) requires ‘org.eclipse.wst.sse.core 0.0.0’ but it could not be found””

ADT Plugin for Eclipse – “Cannot complete the install because one … | LA SMORFIAsays:

[…] here: ADT Plugin for Eclipse – “Cannot complete the install because one … This entry was posted in Uncategorized and tagged adt-plugin, eclipse, facebook, linkedin, […]

Yes I have Android SDK Rev 15 installed. I follow the instructions shown in the guide but I keep getting the same error:

“Cannot complete the install because one or more required items could not be found. Software being installed: Android Development Tools 15.0.0.v201110251216-213216 (com.android.ide.eclipse.adt.feature.group 15.0.0.v201110251216-213216) Missing requirement: Android Development Tools 15.0.0.v201110251216-213216 com.android.ide.eclipse.adt.feature.group 15.0.0.v201110251216-213216) requires ‘org.eclipse.wst.sse.core 0.0.0’ but it could not be found”

Yes I see that now.

Now I have a new problem:

[2011-11-17 14:23:49 – Yoshimi] Android Launch!
[2011-11-17 14:23:49 – Yoshimi] adb is running normally.
[2011-11-17 14:23:49 – Yoshimi] Performing com.v1_4.BC275A5F40BF44C31CE9C26F.com.Act_Home activity launch
[2011-11-17 14:23:49 – Yoshimi] Failed to find an AVD compatible with target ‘Google APIs’.
[2011-11-17 14:23:53 – Yoshimi] Performing com.v1_4.BC275A5F40BF44C31CE9C26F.com.Act_Home activity launch
[2011-11-17 14:23:55 – Yoshimi] Launch canceled!
[2011-11-17 14:26:00 – Yoshimi] ——————————
[2011-11-17 14:26:00 – Yoshimi] Android Launch!
[2011-11-17 14:26:00 – Yoshimi] adb is running normally.
[2011-11-17 14:26:00 – Yoshimi] Performing com.v1_4.BC275A5F40BF44C31CE9C26F.com.Act_Home activity launch
[2011-11-17 14:26:00 – Yoshimi] Failed to find an AVD compatible with target ‘Google APIs’.
[2011-11-17 14:26:08 – Yoshimi] Still no compatible AVDs with target ‘Google APIs’: Aborting launch.
[2011-11-17 14:26:08 – Yoshimi] Performing com.v1_4.BC275A5F40BF44C31CE9C26F.com.Act_Home activity launch

Keeps telling me about an API problem:

[2011-11-17 14:11:21 – Yoshimi] Unable to resolve target ‘Google Inc.:Google APIs:4’

As far as I can tell I have the Google API’s install –> http://screencast.com/t/PUYKNzdpR

Any idea what I’m doing wrong?

ADV = Android Virtual Device and is used to debug or run your App with an Emulator. In AVD Manager click on NEW, insert a name like “test”, select Target Google API an press the button Create ADV. If you want to run your App in your Real Device (Hardware) is not connected.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.